关于小悟志网站地图归档友情链接联系Feed

云上小悟 + 

首页 » 网站建设 »

TinyMCE Advanced插件的表情符号插入功能失效(WP4.2版本)

网站建设
2015年5月13日 / 115次阅读
标签:WordPress插件

文章《TinyMCE Advanced插件的表情符号插入功能失效(WP4.2版本)》的特色图片

我们很多同学都喜欢用TinyMCE Advanced插件来增强WordPress默认编辑器的功能。TinyMCE Advanced插件中,有一个表情符号插入功能,内置20个表情符号,可以任意的插入文章内容,20个表情符号都是本地存储。但是从WordPress4.2版本开始,这个功能不再好用,原因是WordPress内核代码开始使用Emoji表情符号,内核和插件出现了不兼容的情况。

这是TinyMCE Advanced插件的表情按钮功能:

TinyMCE Advanced插件的表情按钮功能

TinyMCE Advanced插件的表情按钮功能

根据对内核代码的分析,WordPress默认自带的表情符号,绝大部分已经切换到了Emoji表情。由于我们一般情况下需要禁止Emoji表情符号(不禁止也无法正常访问Emoji表情符号服务器),因此造成了TinyMCE插件的表情符号不再好用。

看来,只有完全自定义表情符号功能了。这个功能跟评论框插入表情符号一样。后续麦新杰会分享自定义表情符号功能的内容。

本文链接:http://www.maixj.net/wz/tinymce-advanced-biaoqinganniu-5641
云上小悟 麦新杰(QQ:1093023102)

相关文章

评论是美德

无力满足评论实名制,评论对非实名注册用户关闭,有事QQ:1093023102.


前一篇:
后一篇:

栏目精选


©Copyright 麦新杰 Since 2014 云上小悟独立博客版权所有 备案号:苏ICP备14045477号-1

网站二维码
拍拍贷
go to top